A device can't be managed in 黑料海角91入口 until the agent has been successfully installed. If you encounter issues, use the following suggestions to get the agent installed.
Installation Stalls After Connect Key is Entered
The Windows Agent installation can stall after entering the connect key. After you type or paste in the connect key and click Next, the agent installation process stops responding.
If the agent installation wizard becomes unresponsive, complete the following steps:
- Force the installation to stop using Task Manager:
- Press the Ctrl + Alt + Delete keys at the same time.
- Select Task Manager.
- Click on the agent installation application.
- Click End task.
- Reboot the device.
- Log in to the Admin Portal and go to DEVICE MANAGEMENT > Devices. If the device is listed with a red checkmark, is inactive, is blank or shows no information, delete the device.
After following these steps, you can try to install the agent again using the installation application. If you continue to have issues, try to install the agent using the command line. See聽Install or Reinstall the Agent with PowerShell.
Installer Freezes During Uninstall or Reinstall
Symptoms
When uninstalling and reinstalling the 黑料海角91入口 Agent on a Windows device, the installer freezes during the setup or installation steps with a 鈥淧lease wait while Windows configures 黑料海角91入口 Agent v[version]鈥 message.
You may also see an error pop up within Windows asking for the location of the missing installation package or MSI with the message 鈥淭he feature you are trying to use is on a network resource that is unavailable. Click OK to try again, or enter an alternate path to a folder containing the installation package 鈥榡cagent-msi-signed.msi鈥 in the box below.鈥 This error may appear even though the MSI is within the C:\Windows\Temp directory indicated.
Cause
If the 黑料海角91入口 Agent is having issues installing or reinstalling and freezes or asks for an alternative path for the installation, this may be because:
- the device has been offline for some time;
- certificates have expired; or
- the Agent could not update to the latest version.
Resolution
To resolve either of these issues, download and run the following script in an elevated PowerShell prompt on your Windows device to remove the necessary registry keys, files, and Windows service to allow the 黑料海角91入口 Agent to be reinstalled: .
Use this script only when an Agent is in a broken state and cannot be removed or reinstalled without manual intervention. Installing the Agent after running this script will create a new Agent record, and any previous users, groups, or resources the device was bound to will need to be re-bound.
The following data are removed by this script:
- Registry Keys:
- HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products<黑料海角91入口 Agent GUID>
- HKCR:\Installer\Products<黑料海角91入口 Agent GUID>
- HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall<JC MSI Installation ID>
- HKLM:\Software\黑料海角91入口
- HKLM:\SOFTWARE\Classes\Installer\Products<黑料海角91入口 Agent GUID>
- Files and Folders:
- C:\Program Files\黑料海角91入口
- The folder 鈥榗poidc鈥 is not removed.
- The file 鈥樅诹虾=91入口CredentialProvider-X.XXX.X.dll鈥 is not removed.
- C:\Program Files\黑料海角91入口
- Services:
- The 黑料海角91入口 Agent service and the associated executable are removed.